Basic Detailing Tutorial By Finzy

From Serious Sam Wiki
Jump to: navigation, search

This tutorial aims to provide you with some basic ways of extending your architecture and making it look better without using very advanced tools.

When creating basic architecture, I usually use two primary tools: the knife tool and the bevel tool. The knife tool can be used to cut polygons into smaller sections, and while it is more crude than, say, the edge cutter, it can be used to create simple doorways for instance.

The bevel tool can basically be used to create small "holes" into existing architecture, or creating a leveled surface, so to speak (for instance a small platform, raised/lowered areas). Its applications include making windows for instance.

Merge polygons (from the Modify tab to the right) can often be used to ease editing and optimize your model.


Let's try creating a doorway in the first step using the knife tool.


TIP :  For the knife tool to work optimally, I recommend having at least 5 polygons on each axis for your model. I haven't been able to make horizontal cuts on horizontal surfaces with this tool yet (it only seems to work horizontally on a flat plane), so having 5 polygons on every axis removes the need for horizontal cuts and saves time.


TIP #2 :  It's a good idea to have a reference model for the doorway before making any cuts. In my maps for instance, I've often placed wooden tresholds to mark doorway spots for easier editing. These "tresholds" can also prevent players from seeing (possible) bad cuts... :P


  • Go to mesh editor if you haven't already, and select the area of wall polygons you wish to make a doorway to.


TIP :  You may wish to merge the doorway polygons for easier editing by going to the Modify tab on the right and selecting "Merge polygons".


  • With the polygons selected, draw a vertical line along the floor to where you want to make the cut (this will represent the edge of the doorway) To be precise, you may need to have grid view enabled (although the grid only shows up on a flat plane). A slight upwards mouse movement is usually enough to draw the line. You should see a yellow line appear, indicating the direction of the cut. Press Enter to accept the cut and see what happens.


TIP :  If something goes wrong, remember that you can always press Ctrl+Z to undo...


  • Repeat this process on the other edge of the doorway.


  • Once you think you have a good enough shape for the doorway, delete the polygons remaining in the middle between the two cuts and you should have a hole in your model.


  • Next you can simply create a new mesh (primitive) or model on the other side of this hole and then repeat the same cutting process on it to create a hole that matches the hole on your current model. Note that you have to be very precise in placement or you may leave "holes" to your doorway from where you can see the background. Scale the model precisely to make it fit the new hole. If the doorway is supposed to connect two rooms, you may wish to make a small corridor inbetween to ease editing (note: you can also use the "drag align" tool like in world editor to position primitives after they have been created).


  • If you've done all this, you're done! The knife tool doesn't require you to adjust your texturing or uvmaps, so don't worry about that.


In the next step we'll try creating simple windows with the bevel tool.


  • Select the wall polygon(s) you wish to make a window to.


TIP :  You can combine your knowledge from the previous step by using the knife tool in combination with bevel to create bits of walls between your windows, or differently shaped windows.


  • From the Add tab on the right, select "Bevel"...


  • Keep your left mouse button pressed and try moving the mouse around to see what happens to the selected polygons. By drawing your mouse forward, the polygons should move backwards, creating a small hole. Move the camera around to get a better view of your work.


  • By precisely moving the polygons, you should be able to create a straight line (try viewing the beveled surface from the left or right side to see this better). Once satisfied, unselect all polygons and you should have deepened holes to mark the window spots.


  • Repeat same process for all windows you wish to create (you can also just bevel all polygons at once by having them selected at the same time).


NOTE :  All surfaces that have been changed with the bevel tool typically need new surfaces and uvmaps. You should edit your model first before adding any surfaces, otherwise you'll have to redo them later. For beveled horizontal surfaces, you'll typically need a cylinderical uvmap, and you may have to stretch the texture a lot on the U axis to make it appear correctly, like you'd do with walls.


  • If you just want to see the background from the window, delete the polygons inbetween the window walls.


  • ...Alternatively, create a new surface for those window polygons (like you normally would), but set blend mode to translucent. Then, on the base color property, drag your mouse to the left/right on the fourth white box (representing the alpha channel), until the texture begins to fade...once you think it has enough fade, exit to world editor and enable "view background" from the rendering tab.


  • Go back to mesh editor and you should now see through the window to the other side, while having a textured surface on it.


  • However, due to the way the engine handles translucent surfaces and particle effects, we'll need to cut the window surface off and save it as a seperate model. Enter mesh editor again and cut the window polygon(s) (Edit --> Cut). Exit mesh editor and insert a new static model to the window's place. Enter mesh editor on the new model and paste the cut window polygon(s) there; you may wish to move them with the align grid tool closer to the original window frame. Once done, exit again to world editor, and if your cut window doesn't fit the window frame entirely, stretch the model so that it does (something like 1.1 1.1 1.1 is usually enough).


  • Copy the newly created window model and paste it a short distance from the other window (so that there is a small space in the middle), and you should have a window that looks like it's solid.


  • You're now done. But there are lots of more applications for the bevel tool. The best way to learn them is to just experiment with it yourself and see what you can do with it: you could for instance create lowered or raised areas, platforms, etc...


TIP :  Try beveling some ceiling polygons for instance to create ceiling windows.